game crash when activating autopilot on planets and ports

Report bugs for Starport:GE

Moderators: Moleman, Kwijibo, Luna

Post Reply
User avatar
milo
Posts: 844
Joined: Tue Dec 12, 2006 4:58 am
Location: wouldn't you like to know
Contact:

game crash when activating autopilot on planets and ports

Post by milo » Thu Sep 24, 2009 2:17 am

game crash when activating autopilot on planets and ports.

it seems that the plotting calculation for the autopilot is started before you are put into space thus the calculation uses uninitialized variables or something which causes the game to have a fatal error bla bla bla.

not terrible but irritating

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Thu Oct 29, 2009 7:59 pm

I could use help from the community on this one. If you have experienced this crash TODAY (Oct. 29th, 2009) or later, please let me know. Either PM me or reply to this post. You can also email me at support@starportgame.com if you don't have a forums account.

I will ask you to send over a certain log file to me.

Catfish
Posts: 1896
Joined: Sun May 06, 2007 7:47 pm
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Catfish » Thu Oct 29, 2009 8:32 pm

i almost always use autopilot when in ports/planets, never had this problem

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Thu Oct 29, 2009 9:50 pm

It never happens to me either, that's why i need help fixin it. But it does happen to a lot of people.

DarkSide.

Re: game crash when activating autopilot on planets and ports

Post by DarkSide. » Thu Oct 29, 2009 11:02 pm

i used to get it odd times when i had abit of lag. it might just be there computer thats the problem

User avatar
Woots
Posts: 834
Joined: Mon Jun 22, 2009 1:58 am

Re: game crash when activating autopilot on planets and ports

Post by Woots » Thu Oct 29, 2009 11:10 pm

not a problem for me, I just set autopilot for taxis in the port, then go go go!

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Tue Nov 03, 2009 8:13 am

Still looking for someone who has experienced this crash in the last few days.

User avatar
gamanche
Posts: 1319
Joined: Thu Aug 07, 2008 5:25 am
Location: a-c-e

Re: game crash when activating autopilot on planets and ports

Post by gamanche » Tue Nov 03, 2009 1:44 pm

i have not sir

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Tue Nov 10, 2009 3:51 am

Really looking for someone to report this happening recently. Even if it wasn't you that it happened to if you know of anyone it happened to please get in contact with me about it. There will be a token reward.

Catfish
Posts: 1896
Joined: Sun May 06, 2007 7:47 pm
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Catfish » Tue Nov 10, 2009 3:56 am

hehe, watch the replies fly in now :lol:

User avatar
Vekisis
Posts: 46
Joined: Fri Sep 11, 2009 10:08 pm
Location: Tradewars 2002 Galaxy in my Citadel
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Vekisis » Wed Nov 11, 2009 11:11 pm

I have experienced the crash everytime on certain PCs and would like to contribute if possible.

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Thu Nov 12, 2009 10:07 am

Vekisis wrote:I have experienced the crash everytime on certain PCs and would like to contribute if possible.
When was the last time it happened to you? Can you PM me?

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Thu Apr 15, 2010 6:41 am

Still looking to work with people who have experienced this since Thursday April 15th, 2010. If this has happened to you since then, please let me know so that i can have you send me or paste in the contents of PortCrash.log from your StarportGE folder to help me find the problem.

Xander
Posts: 5
Joined: Sun Apr 04, 2010 1:03 am

Re: game crash when activating autopilot on planets and ports

Post by Xander » Thu Apr 15, 2010 5:44 pm

i was experiencing the issue toonces, but only when in newb protection mode, as soon as i lost newb protection, the game stop crashing with auto pilot issue from ports and planets and i have not experienced again since

have not had the issue for several weeks now, was just browsing the forum when i came across the thread

User avatar
Toonces
Site Admin
Posts: 1614
Joined: Mon Oct 04, 2004 10:23 am
Location: Beta Canum Venaticorum
Contact:

Re: game crash when activating autopilot on planets and ports

Post by Toonces » Tue Apr 20, 2010 12:49 pm

still lookin for someone who has experienced this problem to send me their PortCrash.log

thanks!

Post Reply